Tuesday, March 21, 2006

Change of plans - Manaos-Mozilla 0.1.4

From now on, MANaOS (Mozilla Browser) will be running over the maemo-mozilla-engine available at Nokia's official repository, which is btw much more frequently updated. So, all engine level efforts will be coming from there, at least until we get the whole engine sourcebase updated and synchronized to the MOZILLA_1_8_BRANCH (Firefox 1.5.0.x - 2.x trees).

Of course, all credits will be given to who has provided such package(s): Nokia and INdT.

ps: This is not a functionality release, instead we just aim to straighten the situation out. So, those who have installed 0.1.3 be warned that there is nothing new in terms of functionalities, and furthermore, it could bring back to some old bugs for a while (e.g. spatial navigation breakage - crashes on arrow keystroke). Of course 0.1.5 release will fix them up.

Steps to get 0.1.4 installed:
  • Users
    1. Download maemo-browser-mozilla-engine and manaos-maemo-minimo.
    2. Install both packages using AI.
  • for Development:
    • Put these lines to the /etc/apt/sources.list:
deb http://repository.maemo.org maemo1.1 free non-free
deb-src http://repository.maemo.org maemo1.1 free non-free

deb http://repository.maemo.org maemo1.1-extras free non-free
deb-src http://repository.maemo.org maemo1.1-extras free non-free
    • Run
      • fakeroot apt-get update
      • fakeroot apt-get install cpp-3.3
      • fakeroot apt-get install cpp
      • fakeroot apt-get install libidl0
      • fakeroot apt-get install maemo-browser-mozilla-engine
      • fakeroot apt-get install maemo-browser-mozilla-engine-dev
    • Compile or install BIA (bia-minimo-dev)
    • Compile Manaos
PS: Thanks "gotcha" at http://www.blogger.com/comment.g?blogID=18370581&postID=113306925921974055 . You have opened my mind :)

2 comments:

Roger said...

I'm wanting to use TiddlyWiki [1], which absolutely does not work with Opera.

So I thought I'd see how Manaos is doing.

Where do I download the the two AI-ready files you mention in step 1?

Thanks,

Roger

[1] tiddlywiki.com and the version I want to use: http://shared.snapgrid.com/gtd_tiddlywiki.html

Roger said...

Hm-m. "Lots"? I could try out 1.3 then, and move to 1.5 when you're ready . . .

Or send me 1.4 -- my last name is sperberg and my email is the first initial of my first name plus my last name at yahoo.

Thanks!